Upgrade Foswiki from 1.1.8 to 1.1.9

Upgrade reason

According to this official this blog post, Foswiki Release 1.1.9 is a security, performance and bug-fix release.

Pre-installation check

You must have CPAN:version at least at 0.77. If you don't know how to check this , read this. If you need to update it, you can read this section.

Foswiki upgrade

Install the upgrade patch

Go and download the upgrade page here. Put the upgrade patch in the Foswiki root directory and issue the following command :

tar --strip-components=1 -xvzpf Foswiki-upgrade-1.1.9.tgz=

Fix configure script warnings and refresh cache

Go to your bin/configure script and fix for files/directories permissions, I personnaly had to :
chmod 0775 -R pub/
chmod 0775 -R data/
chmod 0775 -R working/

Refresh the foswiki's cache

If you're using the cache system, you have to refresh it. Open your website homepage and add the ?refresh=all URL parameter.

Conclusion

You can see foswiki version in System. Now it should be 1.1.9. Since I din't have any trouble, I don't have to write a troubleshooting section. You can now test and enjoy your upgrade.

-- RainbruUser - 06 Feb 2014
Topic revision: r1 - 06 Feb 2014, RainbruUser

 

HotScripts.comGet RainbruRPG at SourceForge.net. Fast, secure and Free Open Source software downloadsThis site is powered by Foswiki
Active Search Results
Viesearch - Life powered search
Copyright by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Here are my personnal Google+ profile and the related Google+ page.
Ideas, requests, problems regarding RainbruRPG? Send feedback